Come risolvere "WP_Widget è deprecato dalla versione 4.3.0"

Come risolvere "WP_Widget è deprecato dalla versione 4.3.0"

Se sul tuo sito viene mostrato l’errore “Notice: Il metodo del costruttore richiamato per WP_Widget è deprecato dalla versione 4.3.0! Utilizzare invece __construct().” oppure il suo equivalente inglese “Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use __construct() instead.
ed hai bisogno di una soluzione immediata, non esitare: contattami.

Questa notice viene visualizzata da WordPress nel caso vi siano Plugin o Temi che al loro interno definiscono dei Widget per WordPress utilizzando una funzionalità non più supportata da PHP 7: i metodi costruttori in stile PHP 4.

Per risolvere questo errore si devono trovare tra tutti i Plugin ed i Temi che vengono utilizzati sul proprio sito, quelli che utilizzano all’interno dell’inizializzazione di un Widget una tra queste funzioni “parent::WP_Widget“, “$this->WP_Widget” o “NOME_CLASSE->WP_Widget” ed andare a rimpiazzare la funzione “WP_Widget” con il metodo costruttore “__construct” .

Nel caso tu abbia bisogno di ulteriore assistenza, compila il modulo qui sotto.



Se invece hai necessità di un altro tipo di supporto WordPress, controlla quali altri servizi per WordPress posso offrirti.